Results 1 to 2 of 2

Thread: How to solve WordPress Upload HTTP Error/ problem

  1. #1
    Member
    Join Date
    Sep 2011
    Posts
    49
    ΑΡ Credit
    490

    How to solve WordPress Upload HTTP Error/ problem

    WordPress Upload HTTP Error Fix / solution
    Several versions of WordPress ago, I started sporadically encountering a problem while trying to use the Flash uploader in WordPress. Every time I tried to upload something using the Flash uploader, I would just get this HTTP Error message:


    WordPress Upload HTTP Error Fix / solution


    I searched for a solution to the problem and found that it was a bug in one of the older versions of WordPress. Now, several versions later, it’s still happening. I’ve seen it on both WordPress 2.7 and WordPress 2.8. More Googling revealed several tips about about adding directives to the .htaccess file. I tried each of them, but with no success.
    The most puzzling part of this problem for me was that I have several different installations of WordPress on different servers and different versions, but this error was only happening on some of them. After I actually sat down and thought about the problem, I realized that the error was only occurring on the WordPress installations that I had set to be private through the authorization control using my .htaccess files. Those sites have an .htaccess file in the root directory which starts with something like this:
    Code:
    AuthName "private site"
    AuthType Basic
    AuthUserFile /home/private/.htpasswd
    Require valid-user
    This causes a dialog box to pop up when you try to go to the site. You have to specify a correct username and password, as specified in the .htpasswd file, in order to gain access to the site.
    After realizing there might be a connection with this, I tested using the flash uploader on one of my sites with the htaccess authentication turned off. Sure enough, it worked like a charm. So after realizing that the HTTP Error was definitely related to this, a solution was easier to find.
    The solution that worked for me was to create an .htaccess file in the wp-admin directory. The htaccess file should have the following rules in it:
    Code:
    AuthType Basic
    AuthName share
    Satisfy Any
    Order deny,allow
    Allow from all
    
     <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files> </IfModule>
    Since adding this file, I’ve been using the image uploader on my protected sites without a problem.

  2. #2
    Administrator Jennifer's Avatar
    Join Date
    Jul 2010
    Posts
    99
    ΑΡ Credit
    990
    Great work annie.. it is really helpful for me..

Similar Threads

  1. Replies: 3
    Last Post: 11-12-2013, 08:20 AM
  2. Replies: 3
    Last Post: 11-01-2013, 01:43 PM
  3. Anyone else facing problem in WP post editor?
    By Faisal in forum Wordpress
    Replies: 5
    Last Post: 10-30-2013, 09:36 AM
  4. Upload
    By Meer in forum Programming
    Replies: 0
    Last Post: 10-19-2010, 06:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •